Skip to main content
View plugin on GitHub
See starters using this

gatsby-plugin-react-css-modules-scss-support

Provides babel-plugin-react-css-modules with SCSS compilation for Gatsbyjs

Usage

yarn add node-sass gatsby-plugin-react-css-modules-scss-support

Add plugin entry to gatsby-config.js. You can also choose dart-sass to scss compilation. Pass sass module to sassLoader.implementation option of this plugin after yarn add dart-sass.

plugins: [
  {
    resolve: `gatsby-plugin-react-css-modules-scss-support`,
    options: {
      localIdentName: '_[hash:base64:20]',
      sassLoader: {
        // sass-loader options
        implementation: require('sass') // switch the implementation such as dart-sass
      }
    },
  },
],

License

MIT


Docs
Tutorials
Plugins
Blog
Showcase