Skip to main content
View plugin on GitHub
See starters using this

gatsby-plugin-browser-dependencies

Excludes browser-only dependencies from your SSR builds in Gatsby.

Installation

yarn add gatsby-plugin-browser-dependencies

or

npm install --save gatsby-plugin-browser-dependencies

Usage

// gatsby-config.js
module.exports = {
  plugins: [
    {
      resolve: `gatsby-plugin-browser-dependencies`,
      options: {
        dependencies: [
          `auth-js`,
          `browser-only-module`,
        ]
      },
    },
  ],
}

Docs
Tutorials
Plugins
Blog
Showcase