Skip to main content
Community Plugin
View plugin on GitHub
See starters using this

@smarterlabs/gatsby-plugin-browser-dependencies

Excludes browser-only dependencies from your SSR builds in Gatsby.

Installation

yarn add @smarterlabs/gatsby-plugin-browser-dependencies

or

npm install --save @smarterlabs/gatsby-plugin-browser-dependencies

Usage

// gatsby-config.js
module.exports = {
  plugins: [
    {
      resolve: `@smarterlabs/gatsby-plugin-browser-dependencies`,
      options: {
        dependencies: [
          `auth-js`,
          `browser-only-module`,
        ]
      },
    },
  ],
}